#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mu)(?:(?<=[\s,.:;"']|^)\p{Lu}\p{Ll}+(?:[\s]\p{Lu}\p{Ll}+)*(?=[\s,.:;"']|$))|(?<=((?<=[\s,.:;"']|^)\p{Lu}\p{Ll}+(?:[\s]\p{Lu}\p{Ll}+)*(?=[\s,.:;"']|$))\s\()(?:\p{L}*?)(?=\))"
Local $sString = "xin chao (名画) taaat l l l L test Lã Quốc Nghị (nghilq) asdaw guyễn Đức Long (longnd) longChias Kazuma (名画)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")