package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\d+(\.\d+)?A`)
var str = `
<li>ampere à 3A 3.5 Ampere 3.5A .A ne pas prendre</li>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}