re = /^[A-Za-z0-9?:().,'+ -]+(?:\/[A-Za-z0-9?:().,'+ -]+)*$/m
str = 'a
a/b/
a/b/c
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end