#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(([\+\-NnSs])?([0-8]?\d|90)[°˚º^~*\s\-_]+([0-5]?\d|\d)['′\s\-_]+([0-5]?\d|\d)([.]\d*)?["¨˝\s\-_]*([\+\-NnSs])?)([\s\-_:|,;\/\\]+)(([\+\-EeWw])?([0]?\d?\d|1[0-7]\d|180)[°˚º^~*\s\-_]+([0-5]\d|\d)['′\s\-_]+([0-5]?\d|\d)([.]\d*)?["¨˝\s_]*([\+\-EeWw])?)[\s]*$"
Local $sString = "+0 0 0 0 0 0" & @CRLF & _
"0 0 0+ 0 0 0" & @CRLF & _
"0 0 0 +0 0 0" & @CRLF & _
"0 0 0 0 0 0+" & @CRLF & _
"-0 0 0 0 0 0" & @CRLF & _
"0 0 0- 0 0 0" & @CRLF & _
"0 0 0 -0 0 0" & @CRLF & _
"0 0 0 0 0 0-" & @CRLF & _
"+0 0 0 +0 0 0" & @CRLF & _
"0 0 0+ 0 0 0+" & @CRLF & _
"0 0 0+ 0 0 0" & @CRLF & _
"0 0 0 0 0 0+" & @CRLF & _
"" & @CRLF & _
"// check divider" & @CRLF & _
"0 0 0 0 0 0" & @CRLF & _
"0 0 0 0 0 0" & @CRLF & _
"0 0 0|0 0 0" & @CRLF & _
"0 0 0:0 0 0" & @CRLF & _
"0 0 0,0 0 0" & @CRLF & _
"0 0 0;0 0 0" & @CRLF & _
"0 0 0 | 0 0 0" & @CRLF & _
"0 0 0 , 0 0 0" & @CRLF & _
"0 0 0 - 0 0 0" & @CRLF & _
"0 0 0 : 0 0 0" & @CRLF & _
"0 0 0 ; 0 0 0" & @CRLF & _
"0 0 0 ;; 0 0 0" & @CRLF & _
"0 0 0 || 0 0 0" & @CRLF & _
"0 0 0 \ 0 0 0" & @CRLF & _
"0 0 0 / 0 0 0" & @CRLF & _
"0 0 0N 0 0 0" & @CRLF & _
"0 0 0n 0 0 0" & @CRLF & _
"0 0 0S 0 0 0" & @CRLF & _
"0 0 0s 0 0 0" & @CRLF & _
"0 0 0N 0 0 0W" & @CRLF & _
"0 0 0n 0 0 0w" & @CRLF & _
"0 0 0S 0 0 0e" & @CRLF & _
"0 0 0s 0 0 0E" & @CRLF & _
"0 0 0 0 0 0W" & @CRLF & _
"0 0 0 0 0 0w" & @CRLF & _
"0 0 0 0 0 0e" & @CRLF & _
"0 0 0 0 0 0E" & @CRLF & _
"" & @CRLF & _
"//check + and - signs" & @CRLF & _
"" & @CRLF & _
"+0 0 0 0 0 0" & @CRLF & _
"0 0 0+ 0 0 0" & @CRLF & _
"0 0 0 +0 0 0" & @CRLF & _
"0 0 0 0 0 0+" & @CRLF & _
"-0 0 0 0 0 0" & @CRLF & _
"0 0 0- 0 0 0" & @CRLF & _
"0 0 0 -0 0 0" & @CRLF & _
"0 0 0 0 0 0-" & @CRLF & _
"+0 0 0 +0 0 0" & @CRLF & _
"0 0 0+ 0 0 0+" & @CRLF & _
"0 0 0+ 0 0 0" & @CRLF & _
"0 0 0 0 0 0+" & @CRLF & _
"" & @CRLF & _
"// check all zeros" & @CRLF & _
"" & @CRLF & _
"00 00 00 N 000 00 00 E" & @CRLF & _
"00 00 00 N 000 00 0 E" & @CRLF & _
"00 00 00 N 000 0 00 E" & @CRLF & _
"00 00 00 N 000 0 0 E" & @CRLF & _
"00 00 00 N 00 00 00 E" & @CRLF & _
"00 00 00 N 00 00 0 E" & @CRLF & _
"00 00 00 N 00 0 0 E" & @CRLF & _
"00 00 00 N 0 00 00 E" & @CRLF & _
"00 00 00 N 0 0 00 E" & @CRLF & _
"00 00 00 N 0 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 000 00 00 E" & @CRLF & _
"00 00 0 N 000 00 0 E" & @CRLF & _
"00 00 0 N 000 0 00 E" & @CRLF & _
"00 00 0 N 000 0 0 E" & @CRLF & _
"00 00 0 N 00 00 00 E" & @CRLF & _
"00 00 0 N 00 00 0 E" & @CRLF & _
"00 00 0 N 00 0 0 E" & @CRLF & _
"00 00 0 N 0 00 00 E" & @CRLF & _
"00 00 0 N 0 0 00 E" & @CRLF & _
"00 00 0 N 0 0 0 E " & @CRLF & _
"" & @CRLF & _
"00 0 00 N 000 00 00 E" & @CRLF & _
"00 0 00 N 000 00 0 E" & @CRLF & _
"00 0 00 N 000 0 00 E" & @CRLF & _
"00 0 00 N 000 0 0 E" & @CRLF & _
"00 0 00 N 00 00 00 E" & @CRLF & _
"00 0 00 N 00 00 0 E" & @CRLF & _
"00 0 00 N 00 0 0 E" & @CRLF & _
"00 0 00 N 0 00 00 E" & @CRLF & _
"00 0 00 N 0 0 00 E" & @CRLF & _
"00 0 00 N 0 0 0 E" & @CRLF & _
"" & @CRLF & _
"0 00 00 N 000 00 00 E" & @CRLF & _
"0 00 00 N 000 00 0 E" & @CRLF & _
"0 00 00 N 000 0 00 E" & @CRLF & _
"0 00 00 N 000 0 0 E" & @CRLF & _
"0 00 00 N 00 00 00 E" & @CRLF & _
"0 00 00 N 00 00 0 E" & @CRLF & _
"0 00 00 N 00 0 0 E" & @CRLF & _
"0 00 00 N 0 00 00 E" & @CRLF & _
"0 00 00 N 0 0 00 E" & @CRLF & _
"0 00 00 N 0 0 0 E" & @CRLF & _
"" & @CRLF & _
"0 00 0 N 000 00 00 E" & @CRLF & _
"0 00 0 N 000 00 0 E" & @CRLF & _
"0 00 0 N 000 0 00 E" & @CRLF & _
"0 00 0 N 000 0 0 E" & @CRLF & _
"0 00 0 N 00 00 00 E" & @CRLF & _
"0 00 0 N 00 00 0 E" & @CRLF & _
"0 00 0 N 00 0 0 E" & @CRLF & _
"0 00 0 N 0 00 00 E" & @CRLF & _
"0 00 0 N 0 0 00 E" & @CRLF & _
"0 00 0 N 0 0 0 E " & @CRLF & _
"" & @CRLF & _
"0 0 00 N 000 00 00 E" & @CRLF & _
"0 0 00 N 000 00 0 E" & @CRLF & _
"0 0 00 N 000 0 00 E" & @CRLF & _
"0 0 00 N 000 0 0 E" & @CRLF & _
"0 0 00 N 00 00 00 E" & @CRLF & _
"0 0 00 N 00 00 0 E" & @CRLF & _
"0 0 00 N 00 0 0 E" & @CRLF & _
"0 0 00 N 0 00 00 E" & @CRLF & _
"0 0 00 N 0 0 00 E" & @CRLF & _
"0 0 00 N 0 0 0 E" & @CRLF & _
"" & @CRLF & _
"//invalid" & @CRLF & _
"" & @CRLF & _
"0 0 0 N 000 00 E" & @CRLF & _
"0 0 0 N 000 E" & @CRLF & _
"0 0 N 0 0 00 E" & @CRLF & _
"0 N 0 0 0E " & @CRLF & _
"" & @CRLF & _
"// check valid latitude deg vaules" & @CRLF & _
"" & @CRLF & _
"01 00 00 N 000 0 0 E" & @CRLF & _
"1 00 00 N 000 0 0 E" & @CRLF & _
"09 00 00 N 000 0 0 E" & @CRLF & _
"9 00 00 N 000 0 0 E" & @CRLF & _
"89 00 00 N 000 0 0 E" & @CRLF & _
"90 00 01 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"+00 00 00 N 000 0 0 E" & @CRLF & _
"+0 00 00 N 000 0 0 E" & @CRLF & _
"+01 00 00 N 000 0 0 E" & @CRLF & _
"+1 00 00 N 000 0 0 E" & @CRLF & _
"+09 00 00 N 000 0 0 E" & @CRLF & _
"+9 00 00 N 000 0 0 E" & @CRLF & _
"+89 00 00 N 000 0 0 E" & @CRLF & _
"+90 00 01 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"-00 00 00 N 000 0 0 E" & @CRLF & _
"-0 00 00 N 000 0 0 E" & @CRLF & _
"-01 00 00 N 000 0 0 E" & @CRLF & _
"-1 00 00 N 000 0 0 E" & @CRLF & _
"-09 00 00 N 000 0 0 E" & @CRLF & _
"-9 00 00 N 000 0 0 E" & @CRLF & _
"-89 00 00 N 000 0 0 E" & @CRLF & _
"-90 00 01 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 00 000 0 0" & @CRLF & _
"+0 00 00 000 0 0" & @CRLF & _
"+01 00 00 000 0 0" & @CRLF & _
"+1 00 00 000 0 0" & @CRLF & _
"+09 00 00 000 0 0" & @CRLF & _
"+9 00 00 000 0 0" & @CRLF & _
"+89 00 00 000 0 0" & @CRLF & _
"+90 00 01 000 0 0" & @CRLF & _
"" & @CRLF & _
"//invalid" & @CRLF & _
"91 00 01 N 000 0 0 E" & @CRLF & _
"000 00 01 N 000 0 0 E" & @CRLF & _
"089 00 01 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"// check valid latitude minute vaules" & @CRLF & _
"" & @CRLF & _
"00 01 00 N 000 0 0 E" & @CRLF & _
"00 1 00 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 09 00 N 000 0 0 E" & @CRLF & _
"00 9 00 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 59 00 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"//invalid" & @CRLF & _
"" & @CRLF & _
"00 60 00 N 000 0 0 E" & @CRLF & _
"00 59.55 00 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"// check valid latitude second vaules" & @CRLF & _
"" & @CRLF & _
"00 00 01 N 000 0 0 E" & @CRLF & _
"00 00 1 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 09 N 000 0 0 E" & @CRLF & _
"00 00 9 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 59 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 01.001 N 000 0 0 E" & @CRLF & _
"00 00 1.001 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 09.001 N 000 0 0 E" & @CRLF & _
"00 00 9.001 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 59.001 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"//invalid" & @CRLF & _
"" & @CRLF & _
"00 00 60 N 000 0 0 E" & @CRLF & _
"00 00 60.999 N 000 0 0 E" & @CRLF & _
"" & @CRLF & _
"//check valid longitute degree values" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 001 0 0 E" & @CRLF & _
"00 00 0 N 01 0 0 E" & @CRLF & _
"00 00 0 N 1 0 0 E" & @CRLF & _
"00 00 0 N 10 0 0 E" & @CRLF & _
"00 00 0 N 99 0 0 E" & @CRLF & _
"00 00 0 N 100 0 0 E" & @CRLF & _
"00 00 0 N 179 0 0 E" & @CRLF & _
"00 00 0 N 79 0 0 E" & @CRLF & _
"00 00 0 N 180 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 001° 0 0 E" & @CRLF & _
"00 00 0 N 01° 0 0 E" & @CRLF & _
"00 00 0 N 1° 0 0 E" & @CRLF & _
"00 00 0 N 10° 0 0 E" & @CRLF & _
"00 00 0 N 99° 0 0 E" & @CRLF & _
"00 00 0 N 100° 0 0 E" & @CRLF & _
"00 00 0 N 179° 0 0 E" & @CRLF & _
"00 00 0 N 79° 0 0 E" & @CRLF & _
"00 00 0 N 180° 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 001˚ 0 0 E" & @CRLF & _
"00 00 0 N 01˚ 0 0 E" & @CRLF & _
"00 00 0 N 1˚ 0 0 E" & @CRLF & _
"00 00 0 N 10˚ 0 0 E" & @CRLF & _
"00 00 0 N 99˚ 0 0 E" & @CRLF & _
"00 00 0 N 100˚ 0 0 E" & @CRLF & _
"00 00 0 N 179˚ 0 0 E" & @CRLF & _
"00 00 0 N 79˚ 0 0 E" & @CRLF & _
"00 00 0 N 180˚ 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 001º 0 0 E" & @CRLF & _
"00 00 0 N 01º 0 0 E" & @CRLF & _
"00 00 0 N 1º 0 0 E" & @CRLF & _
"00 00 0 N 10º 0 0 E" & @CRLF & _
"00 00 0 N 99º 0 0 E" & @CRLF & _
"00 00 0 N 100º 0 0 E" & @CRLF & _
"00 00 0 N 179º 0 0 E" & @CRLF & _
"00 00 0 N 79º 0 0 E" & @CRLF & _
"00 00 0 N 180º 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 001^ 0 0 E" & @CRLF & _
"00 00 0 N 01^ 0 0 E" & @CRLF & _
"00 00 0 N 1^ 0 0 E" & @CRLF & _
"00 00 0 N 10^ 0 0 E" & @CRLF & _
"00 00 0 N 99^ 0 0 E" & @CRLF & _
"00 00 0 N 100^ 0 0 E" & @CRLF & _
"00 00 0 N 179^ 0 0 E" & @CRLF & _
"00 00 0 N 79^ 0 0 E" & @CRLF & _
"00 00 0 N 180^ 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 001~ 0 0 E" & @CRLF & _
"00 00 0 N 01~ 0 0 E" & @CRLF & _
"00 00 0 N 1~ 0 0 E" & @CRLF & _
"00 00 0 N 10~ 0 0 E" & @CRLF & _
"00 00 0 N 99~ 0 0 E" & @CRLF & _
"00 00 0 N 100~ 0 0 E" & @CRLF & _
"00 00 0 N 179~ 0 0 E" & @CRLF & _
"00 00 0 N 79~ 0 0 E" & @CRLF & _
"00 00 0 N 180~ 0 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 001* 0 0 E" & @CRLF & _
"00 00 0 N 01* 0 0 E" & @CRLF & _
"00 00 0 N 1* 0 0 E" & @CRLF & _
"00 00 0 N 10* 0 0 E" & @CRLF & _
"00 00 0 N 99* 0 0 E" & @CRLF & _
"00 00 0 N 100* 0 0 E" & @CRLF & _
"00 00 0 N 179* 0 0 E" & @CRLF & _
"00 00 0 N 79* 0 0 E" & @CRLF & _
"00 00 0 N 180* 0 0 E" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"//invalid" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 181 0 0 E" & @CRLF & _
"00 00 0 N 1111 0 0 E" & @CRLF & _
"00 00 0 N 181° 0 0 E" & @CRLF & _
"00 00 0 N 1111° 0 0 E" & @CRLF & _
"00 00 0 N 181˚ 0 0 E" & @CRLF & _
"00 00 0 N 1111˚ 0 0 E" & @CRLF & _
"00 00 0 N 181º 0 0 E" & @CRLF & _
"00 00 0 N 1111º 0 0 E" & @CRLF & _
"00 00 0 N 181^ 0 0 E" & @CRLF & _
"00 00 0 N 1111^ 0 0 E" & @CRLF & _
"00 00 0 N 181~ 0 0 E" & @CRLF & _
"00 00 0 N 1111~ 0 0 E" & @CRLF & _
"00 00 0 N 181* 0 0 E" & @CRLF & _
"00 00 0 N 1111* 0 0 E" & @CRLF & _
"" & @CRLF & _
"//check valid longitute minute values" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 000 01 0 E" & @CRLF & _
"00 00 0 N 000 1 0 E" & @CRLF & _
"00 00 0 N 000 9 0 E" & @CRLF & _
"00 00 0 N 000 09 0 E" & @CRLF & _
"00 00 0 N 000 10 0 E" & @CRLF & _
"00 00 0 N 000 59 0 E" & @CRLF & _
"00 00 0 N 000 5 0 E" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 000 01' 0 E" & @CRLF & _
"00 00 0 N 000 1' 0 E" & @CRLF & _
"00 00 0 N 000 9' 0 E" & @CRLF & _
"00 00 0 N 000 09' 0 E" & @CRLF & _
"00 00 0 N 000 10' 0 E" & @CRLF & _
"00 00 0 N 000 59' 0 E" & @CRLF & _
"00 00 0 N 000 5' 0 E" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 000 01′ 0 E" & @CRLF & _
"00 00 0 N 000 1′ 0 E" & @CRLF & _
"00 00 0 N 000 9′ 0 E" & @CRLF & _
"00 00 0 N 000 09′ 0 E" & @CRLF & _
"00 00 0 N 000 10′ 0 E" & @CRLF & _
"00 00 0 N 000 59′ 0 E" & @CRLF & _
"00 00 0 N 000 5′ 0 E" & @CRLF & _
"" & @CRLF & _
"//invalid" & @CRLF & _
"" & @CRLF & _
"00 00 0 N 000 60 0 E" & @CRLF & _
"00 00 0 N 000 61 0 E" & @CRLF & _
"00 00 0 N 000 60' 0 E" & @CRLF & _
"00 00 0 N 000 61' 0 E" & @CRLF & _
"00 00 0 N 000 60′ 0 E" & @CRLF & _
"00 00 0 N 000 61′ 0 E" & @CRLF & _
"" & @CRLF & _
"// check degree symbols" & @CRLF & _
"" & @CRLF & _
"0° 0' 0" 0° 0' 0"" & @CRLF & _
"0° 0' 0" 0˚ 0' 0"" & @CRLF & _
"0° 0' 0" 0º 0' 0"" & @CRLF & _
"0° 0' 0" 0^ 0' 0"" & @CRLF & _
"0° 0' 0" 0~ 0' 0"" & @CRLF & _
"0° 0' 0" 0* 0' 0"" & @CRLF & _
"" & @CRLF & _
"0˚ 0' 0" 0° 0' 0"" & @CRLF & _
"0˚ 0' 0" 0˚ 0' 0"" & @CRLF & _
"0˚ 0' 0" 0º 0' 0"" & @CRLF & _
"0˚ 0' 0" 0^ 0' 0"" & @CRLF & _
"0˚ 0' 0" 0~ 0' 0"" & @CRLF & _
"0˚ 0' 0" 0* 0' 0"" & @CRLF & _
"" & @CRLF & _
"0º 0' 0" 0° 0' 0"" & @CRLF & _
"0º 0' 0" 0˚ 0' 0"" & @CRLF & _
"0º 0' 0" 0º 0' 0"" & @CRLF & _
"0º 0' 0" 0^ 0' 0"" & @CRLF & _
"0º 0' 0" 0~ 0' 0"" & @CRLF & _
"0º 0' 0" 0* 0' 0"" & @CRLF & _
"" & @CRLF & _
"0^ 0' 0" 0° 0' 0"" & @CRLF & _
"0^ 0' 0" 0˚ 0' 0"" & @CRLF & _
"0^ 0' 0" 0º 0' 0"" & @CRLF & _
"0^ 0' 0" 0^ 0' 0"" & @CRLF & _
"0^ 0' 0" 0~ 0' 0"" & @CRLF & _
"0^ 0' 0" 0* 0' 0"" & @CRLF & _
"" & @CRLF & _
"0~ 0' 0" 0° 0' 0"" & @CRLF & _
"0~ 0' 0" 0˚ 0' 0"" & @CRLF & _
"0~ 0' 0" 0º 0' 0"" & @CRLF & _
"0~ 0' 0" 0^ 0' 0"" & @CRLF & _
"0~ 0' 0" 0~ 0' 0"" & @CRLF & _
"0~ 0' 0" 0* 0' 0"" & @CRLF & _
"" & @CRLF & _
"0* 0' 0" 0° 0' 0"" & @CRLF & _
"0* 0' 0" 0˚ 0' 0"" & @CRLF & _
"0* 0' 0" 0º 0' 0"" & @CRLF & _
"0* 0' 0" 0^ 0' 0"" & @CRLF & _
"0* 0' 0" 0~ 0' 0"" & @CRLF & _
"0* 0' 0" 0* 0' 0"" & @CRLF & _
"" & @CRLF & _
"//check minute symbols" & @CRLF & _
"" & @CRLF & _
"0° 00' 00 000° 00' 00"" & @CRLF & _
"0° 00' 00 000° 00' 00"" & @CRLF & _
"0° 00' 00" 000° 00' 00 " & @CRLF & _
"0° 00' 00" 000° 00' 00"" & @CRLF & _
"" & @CRLF & _
"0° 00′ 00 000° 00′ 00"" & @CRLF & _
"0° 00′ 00 000° 00′ 00"" & @CRLF & _
"0° 00′ 00" 000° 00′ 00 " & @CRLF & _
"0° 00′ 00" 000° 00′ 00"" & @CRLF & _
"" & @CRLF & _
"0° 00' 00 000° 00′ 00"" & @CRLF & _
"0° 00' 00 000° 00′ 00"" & @CRLF & _
"0° 00' 00" 000° 00′ 00 " & @CRLF & _
"0° 00' 00" 000° 00′ 00"" & @CRLF & _
"" & @CRLF & _
"0° 00′ 00 000° 00' 00"" & @CRLF & _
"0° 00′ 00 000° 00' 00"" & @CRLF & _
"0° 00′ 00" 000° 00' 00 " & @CRLF & _
"0° 00′ 00" 000° 00' 00"" & @CRLF & _
"" & @CRLF & _
"//check second symbols" & @CRLF & _
"" & @CRLF & _
"0° 00' 00" N 000° 00' 00"" & @CRLF & _
"0° 00' 00.666" N 000° 00' 00" E" & @CRLF & _
"0° 00' 00" N 000° 00' 00.000" E" & @CRLF & _
"0° 00' 00" N 000° 00' 00"" & @CRLF & _
"" & @CRLF & _
"0° 00' 00¨ N 000° 00' 00¨ E" & @CRLF & _
"0° 00' 00.666¨ N 000° 00' 00¨" & @CRLF & _
"0° 00' 00¨ N 000° 00' 00.000¨ E" & @CRLF & _
"0° 00' 00¨ N 000° 00' 00¨ E" & @CRLF & _
"" & @CRLF & _
"0° 00' 00˝ N 000° 00' 00˝ E" & @CRLF & _
"0° 00' 00.666˝ N 000° 00' 00˝" & @CRLF & _
"0° 00' 00˝ N 000° 00' 00.000˝ E" & @CRLF & _
"0° 00' 00˝ N 000° 00' 00˝ E" & @CRLF & _
"" & @CRLF & _
"//check full dms with differing spaces" & @CRLF & _
"" & @CRLF & _
"0°00'00˝N 000°00'00˝E" & @CRLF & _
"0 °00'00˝N 000°00'00˝E" & @CRLF & _
"0 ° 00 '00˝N 000°00'00˝E" & @CRLF & _
"0 ° 00 '00 ˝N 000°00'00˝E" & @CRLF & _
"0 ° 00 '00˝ N 000°00'00˝E" & @CRLF & _
"0 ° 00 '00˝ N 000 ° 00'00˝E" & @CRLF & _
"0 ° 00 '00˝ N 000 ° 00 '00˝E" & @CRLF & _
"0 ° 00 '00˝ N 000 ° 00 ' 00˝E" & @CRLF & _
"0 ° 00 '00˝ N 000 ° 00 ' 00 ˝E" & @CRLF & _
"0 ° 00 '00˝ N 000 ° 00 ' 00 ˝ E" & @CRLF & _
"" & @CRLF & _
"//check full dms prefix / suffix" & @CRLF & _
"" & @CRLF & _
"0° 00' 00˝N 000° 00'00˝E" & @CRLF & _
"0° 00' 00˝N 000° 00'00˝" & @CRLF & _
"0° 00' 00˝ 000° 00'00˝E" & @CRLF & _
"N0° 00' 00˝ E000° 00'00˝" & @CRLF & _
"N0° 00' 00˝ 000° 00'00˝E" & @CRLF & _
"0° 00' 00˝ E000° 00'00˝" & @CRLF & _
"N0° 00' 00˝N 000° 00'00˝" & @CRLF & _
"0° 00' 00˝ E000° 00'00˝E" & @CRLF & _
"" & @CRLF & _
"0° 00' 00˝S 000° 00'00˝E" & @CRLF & _
"0° 00' 00˝S 000° 00'00˝" & @CRLF & _
"0° 00' 00˝ 000° 00'00˝E" & @CRLF & _
"S0° 00' 00˝ E000° 00'00˝" & @CRLF & _
"S0° 00' 00˝ 000° 00'00˝E" & @CRLF & _
"0° 00' 00˝ E000° 00'00˝" & @CRLF & _
"S0° 00' 00˝S 000° 00'00˝" & @CRLF & _
"0° 00' 00˝ E000° 00'00˝E" & @CRLF & _
"" & @CRLF & _
"0° 00' 00˝N 000° 00'00˝W" & @CRLF & _
"0° 00' 00˝N 000° 00'00˝" & @CRLF & _
"0° 00' 00˝ 000° 00'00˝W" & @CRLF & _
"N0° 00' 00˝ W000° 00'00˝" & @CRLF & _
"N0° 00' 00˝ 000° 00'00˝W" & @CRLF & _
"0° 00' 00˝ W000° 00'00˝" & @CRLF & _
"N0° 00' 00˝N 000° 00'00˝" & @CRLF & _
"0° 00' 00˝ W000° 00'00˝W" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"0° 00' 00˝S 000° 00'00˝W" & @CRLF & _
"0° 00' 00˝S 000° 00'00˝" & @CRLF & _
"0° 00' 00˝ 000° 00'00˝W" & @CRLF & _
"S0° 00' 00˝ W000° 00'00˝" & @CRLF & _
"S0° 00' 00˝ 000° 00'00˝W" & @CRLF & _
"0° 00' 00˝ W000° 00'00˝" & @CRLF & _
"S0° 00' 00˝S 000° 00'00˝" & @CRLF & _
"0° 00' 00˝ E000° 00'00˝W" & @CRLF & _
"" & @CRLF & _
"//invalid" & @CRLF & _
"" & @CRLF & _
"0° 00' 00˝E 000° 00'00˝E" & @CRLF & _
"0° 00' 00˝E 000° 00'00˝W" & @CRLF & _
"0° 00' 00˝W 000° 00'00˝W" & @CRLF & _
"0° 00' 00˝N 000° 00'00˝S" & @CRLF & _
"0° 00' 00˝N 000° 00'00˝N" & @CRLF & _
"0° 00' 00˝S 000° 00'00˝S" & @CRLF & _
"0° 00' 00˝W 000° 00'00˝S" & @CRLF & _
"0° 00' 00˝W 000° 00'00˝N" & @CRLF & _
"0° 00' 00˝E 000° 00'00˝S" & @CRLF & _
"0° 00' 00˝E 000° 00'00˝N" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")