package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[A-Z]{2}[0-9]{2}[A-Z]{2}[0-9]{4}$`)
var str = `GJ12VC2345`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}