package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:\?*[a-zA-Z\d]){2}[a-zA-Z\d?]*\*?$`)
var str = `abcd
?bcd
ab??
ab*
ab?*
??cd
*ab
???
ab cd
abcd
a?????b????`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}