import re
regex = re.compile(r"^0*(0)$|^0+", flags=re.MULTILINE)
test_str = ("005\n"
"0AB\n"
"000\n"
"0")
subst = "$1"
result = regex.sub(subst, test_str)
if result:
print(result)