$re = '/\s+(?=\S*$)/m';
$str = 'short string
this is the longer string';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);