const regex = /^.*? "|"$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^.*? "|"$', 'gm')
const str = `string(18) "This is an example"`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);