$re = '/()/m';
$str = '1.5-200.10.*
1.5.10.255
1.200.10.1
1.1.10.10
1.5.11.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);