const regex = /(\b(?'first_word'[A-Z](?!([A-Z0-9]*\b|[[:alnum:]]*_)(?# the word isn't in all caps and doesn't contain underscores))(?:[a-z0-9]*)))|(\G(?'trailing_word'[A-Z][a-z0-9]*))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\b(?\'first_word\'[A-Z](?!([A-Z0-9]*\\b|[[:alnum:]]*_)(?# the word isn\'t in all caps and doesn\'t contain underscores))(?:[a-z0-9]*)))|(\\G(?\'trailing_word\'[A-Z][a-z0-9]*))', 'gm')
const str = `PascalCase
Pascal
PascalCaseCase
Pascal684Case
Pas45calCase
PascalCase6523Case
PascalCaseCaseCase
PPascal
PascalCCase
camelCase
// some random commentary with Capitalized and SCREAMING letters
SCREAMING_SNAKE_CASE
Pascal_Snake_Case
`;
const subst = `\L${first_word}${trailing_word:+_\L${trailing_word}:}`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);