re = /(?=((?:(\w+)(?!(?:\2)).\2)))/i
str = 'bbbabbb mnonopoao
# ono and oao doesn\'t match!!!'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end