#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(\d{4}-\d{2}-\d{2}\ \d+:\d+:\d+):" & @CRLF & _
"(?:(?!^\d{4})[\s\S])+?" & @CRLF & _
"\QTHIS IS MATCHED STRING\E"
Local $sString = "2018-07-10 10:03:01: random text1" & @CRLF & _
"2018-07-10 10:03:02: random text2" & @CRLF & _
"2018-07-10 10:03:03: random text3" & @CRLF & _
" more text" & @CRLF & _
" and more" & @CRLF & _
" THIS IS MATCHED STRING" & @CRLF & _
"2018-07-10 10:03:04: random text4"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")