# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<=^|[\n;](?:[\t ]*(?:\w+ )?)?)import\s*(?<type>type(?=\s+))?(?:[\s\"']*(?<imports>[\w\t\n\r \"$'*,/{}-]+?)\s+from\s*)?[\"']\s*(?<specifier>(?:(?<='\s*)[^']*[^\s'](?=\s*'))|(?:(?<=\"\s*)[^\"]*[^\s\"](?=\s*\")))\s*[\"'](?:\s+assert\s+(?<assertion>{[\w\t\n\r \"':]+?}))?(?=[\s;]*)"
test_str = ("/**\n"
" * @file Interfaces\n"
" * @module mlly/interfaces\n"
" */\n\n"
"export type { default as DynamicImport } from './import-dynamic'\n"
"export type { default as StaticImport } from './import-static'\n"
"export type { default as ResolveOptions } from './options-resolve'\n"
"export type { default as ResolveAliasOptions } from './options-resolve-alias'\n"
"export type { default as Statement } from './statement'\n"
"export type { default as ExportStatement } from './statement-export'\n"
"export type { default as ImportStatement } from './statement-import'\n"
"export type { default as RequireStatement } from './statement-require'\n\n"
"import { CONDITIONS, RESOLVE_EXTENSIONS } from '#src/constants'\n"
"import type { ResolveOptions } from '#src/interfaces'\n"
"import type { SpecifierType } from '#src/types'\n"
"import isBuiltin from '@flex-development/is-builtin'\n"
"import { moduleResolve, type ErrnoException } from 'import-meta-resolve'\n"
"import { pathToFileURL, URL } from 'node:url'\n"
"import upath from 'upath'\n"
"import toBareSpecifier from './to-bare-specifier'\n"
"import toRelativeSpecifier from './to-relative-specifier'\n"
"import 'file:///home/dir/file.ts'\n\n"
"import pkg from './package.json' assert { type:'json' }\n"
"import * as color from 'colorette'\n"
"import consola from 'consola'\n"
"import { defu } from 'defu'\n"
"import type { Format } from 'esbuild'\n"
"import fse from 'fs-extra'\n"
"import * as pathe from 'pathe'\n"
"import { resolve } from 'node:path'\n"
"import url from 'node:url'\n"
"import type { PackageJson } from 'pkg-types'\n"
"import pb from 'pretty-bytes'\n"
"import { EXT_DTS_REGEX, IGNORE_PATTERNS } from './config/constants'\n"
"import loadBuildConfig from './config/load'\n"
"import type { Config, Entry, Result } from './interfaces'\n"
"import type { OutputExtension } from './types'\n"
"import { readPackage, type PackageJson } from \"read-pkg\"\n"
"import {OutputExtension} from './types'\n"
"import analyzeResults from './utils/analyze-results'\n"
"import esbuilder from './utils/esbuilder'; import write from './utils/write';import write2 from './utils/write'\n"
"// import write from './utils/write'\n"
"import 'side-effect.mjs'\n"
"import type StatementType from '../types/statement-type'\n"
"import type {\n"
" BuildOptions,\n"
" BuildResult,\n"
" OutputFile,\n"
" Plugin,\n"
" PluginBuild\n"
"} from './esbuild'\n\n"
"import defaultExport from \"module-name\";\n"
"import * as name from \"module-name\";\n"
"import { export1 } from \"module-name\";\n"
"import { export1 as alias1 } from \"module-name\";\n"
"import { default as alias } from \"module-name\";\n"
"import { export1, export2 } from \"module-name\";\n"
"import { export1, export2 as alias2 } from \"module-name\";\n"
"import { 'string name' as alias } from \"module-name\";\n"
"import { \"string name\" as alias } from \"module-name\";\n"
"import defaultExport, { export1 } from \"module-name\";\n"
"import defaultExport, * as name from \"module-name\";\n"
"import \"module-name\";\n"
"import 'module-name';\n"
"import './polyfill.mjs'\n"
"import { \"h-i\" as hi } from './hi.js'\n"
"import { 'j-k' as jk } from \"./jk.js\"\n\n"
"declare module '__fixtures__/values' {\n"
" import MAX_VALUE from '#fixtures/max-value'\n"
" import MIN_VALUE from '#fixtures/min-value'\n"
"}\n\n"
"const ERR_UNSUPPORTED_DIR_IMPORT: NodeErrorConstructor<\n"
" ErrorConstructor,\n"
" [string, string]\n"
"> = createNodeError(\n"
" ErrorCode.ERR_UNSUPPORTED_DIR_IMPORT,\n"
" Error,\n"
" 'Directory import '%s' is not supported resolving ES modules imported from %s'\n"
")\n\n"
"const text: string = await resolveModules(output.text, {\n"
" conditions: [format === 'esm' ? 'import' : 'require'],\n"
" ext: ext as Ext,\n"
" extensions,\n"
" parent\n"
"})\n\n"
"/**\n"
" * @example\n"
" * import write from './utils/write'\n"
" * write()\n"
" */\n\n"
"import { 'j-k' as jk } from \"./jk.js\"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.