#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)((\d|:)+)\s(.+)"
Local $sString = "0:08 Waltz No. 2 (Dmitri Shostakovitch)" & @CRLF & _
"4:01 Dance of the Knights (Sergei Prokofiev)" & @CRLF & _
"9:42 Sabre Dance (Aram Khachaturian)" & @CRLF & _
"12:09 1812 Overture Finale (Pyotr Ilyich Tchaikovsky) (My Absolute Favorite One)" & @CRLF & _
"15:57 Flight of the Bumblebee "From The Tale of Tsar Sultan" (Nikolai Rimsky-Korsakov)" & @CRLF & _
"19:31 Rite of Spring Sacrifical Dance (Igor Stravinsky)" & @CRLF & _
"24:09 Piano Concerto No. 2 (Moderato) (Sergei Rachmaninoff)" & @CRLF & _
"34:22 Polovtsian Dances "From Prince Igor" (Alexander Borodin)" & @CRLF & _
"39:20 Etude Op. 8 No. 12 (Alexander Scriabin)" & @CRLF & _
"41:51 Sailors' Dance (Reinhold Gliere)" & @CRLF & _
"45:13 Dance of the Sugar Plum Fairy (Pyotr Ilylich Tchaikovsky)" & @CRLF & _
"47:46 Piano Concerto No. 1 (Allegro) (Pyotr Ilylich Tchaikovsky)" & @CRLF & _
"51:54 Ruslan and Lyudmila Overture (Mikhail Glinka)" & @CRLF & _
"54:51 Swan Lake Waltz (Pyotr Ilyich Tchaikovsky)" & @CRLF & _
"1:01:47 Dance of the Pagan Monster (Sergei Prokofiev)" & @CRLF & _
"1:05:01 Overture from the Children of Captain Grant (Isaak Dunaevsky)" & @CRLF & _
"1:08:52 Symphony No. 5 (Allegro Non Troppo) (Dmitri Shostakovitch) (My Favorite One)" & @CRLF & _
"1:12:00 Swan Theme (Pyotr Ilyich Tchaikovsky)" & @CRLF & _
"1:14:53 Night on Bald Mountain (Modest Mussorgsky)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")