import re
regex = re.compile(r"[^0-9.,]", flags=re.MULTILINE)
test_str = "(626.123*) 34a2- 4387,222222)"
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)