$re = '/_(?:#[[:alpha:]]\w* +)+(?=_)/m';
$str = '"_#long #string #of #multiple #words #with #hash #tags _ "
"_#long #string #of #3multiple #words #with #hash #tags _ "
"_#long #string #of #multiple3 #words #with #hash #tags _ "';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);