#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\b(?=(?:[a-z0-9]*[A-Z]){4})(?=(?:[A-Z0-9]*[a-z]){2})(?=[a-zA-Z]*[0-9])[A-Za-z0-9]{5,30}\b"
Local $sString = "https://stackoverflow.com/Abcde3FGhiDE/Zyx23 should match: Abcde3FGhiDE" & @CRLF & _
"|a|b|c|AbcdEFGH123|456Ac should match: AbcdEFG123" & @CRLF & _
"P A Abcde3FGhiDE Z H should match: Abcde3FGhiDE" & @CRLF & _
"ZZ123!Abcde3FGhiDE!123 should match: Abcde3FGhiDE" & @CRLF & _
"" & @CRLF & _
"<HeLLoWoRlD"123" & @CRLF & _
"|A|b|c|D|E|F|1|" & @CRLF & _
"NULLLLLLLLLLLLLLLLLLLLLLllll 1" & @CRLF & _
"IAMoverTHELIMITTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTTT3"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")