import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=AAAAA).*?(?=ZZZZZ)";
final String string = "[]}6778:---esghsrth\"id\":\"95907bc09-568976456-c6a5a-4f87g\"[]}6778:---AAAAA{[]}bla...esghshrth\"id\":\"95907bc09-568976456-c6a5a-4f87g\"[]}6778:---esghsrth\"id\":\"95907bc09-568976456-c6a5a-4f87g\"[]}6778:---esghsrth\"id\":\"95907bc09-568976456-c6a5a-4f87g\"[]}6778:---esghsrth\"id\":\"95907bc09-568976456-c6a5a-4f87g\"[]}6778:---esghsrth\"id\":\"95907bc09-568976456-c6a5a-4f87g\"[]}6778:---esghsrth\"id\":\"95907bc09-568976456-c6a5a-4f87g\"[]}6778:---esghsrth\"id\":\"95907bc09-568976456-c6a5a-4f87g\"[]}6778:---ZZZZZ[]}6778:---esghsrth\"id\":\"95907bc09-568976456-c6a5a-4f87g\"[]}6778:---";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}