using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=\""id\"":\"").*?(?=\"")";
string input = @"{[]}bla...esghshrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---esghsrth""id"":""95907bc09-568976456-c6a5a-4f87g""[]}6778:---";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}