package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?ms)\{\{Template[^\{]*(?:\{\{[^\}]*\}\}[^\{]*)*?[^\{]*\}\}`)
var str = `lots of gibberish
before what I want{{Template
| x = 1
| y = {{Convert|1|2}}|z= {{Convert|3|4}}}}more gibberish
here too. {{Other|test}}
lots of gibberish
before what I want{{Template
| x = 1
| y = 2|z= 3}}more gibberish
here too. {{Other|test}}`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}