const regex = /([a-z0-9 .]+)(, ((unit|apt|#|suite) [0-9]+))?/gi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('([a-z0-9 .]+)(, ((unit|apt|#|suite) [0-9]+))?', 'gi')
const str = `1234 Main St., suite 10`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}