use strict;
my $str = '2023-06-26 00:00:00|Execution error for request 52262275. Reason: ESS-07033 Job logic indicated a system error occurred while executing an asynchronous java job for request 52262275. Job error is: one or more subbatches has failed to generate feed.|111975431';
my $regex = qr~(.*Execution error for request [0-9]+. Reason: ESS-07033 Job logic indicated a system error occurred while executing an asynchronous java job for request [0-9]+. Job error is: one or more subbatches has failed to generate feed..*)~p;
my $subst = '$1|959361986';
my $result = $str =~ s~$regex~$subst~r;
print "The result of the substitution is' $result\n";