const regex = /(.*) ((youtube.com) | (youtu.be) | (www.youtube.com) ) (.*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(.*) ((youtube.com) | (youtu.be) | (www.youtube.com) ) (.*)', 'gmi')
const str = `http://youtu.be/cCnrX1w5luM
www.youtube.com/cCnrX1w5luM
youtu.be/cCnrX1w5luM
https://www.youtube.com/watch?v=nzj7Wg4DAbs
http://www.youtube.com/watch?v=nzj7Wg4DAbs
youtube.com/watch?v=nzj7Wg4DAbs
http://www.youtube.com/watch?v=-wtIMTCHWuI
http://www.youtube.com/v/-wtIMTCHWuI?version=3&autohide=1
http://youtu.be/-wtIMTCHWuI
http://www.youtube.com/oembed?url=http%3A//www.youtube.com/watch?v%3D-wtIMTCHWuI&format=json
Hello https://www.youtube.com/watch?v=nzj7Wg4DAbs world
`;
const subst = `<iframe src="htpp://youtube.com$6" allowfullscreen></frame>`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);