using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[^\s$]*\$[^$]+\$[^\s$]*";
string input = @"'Slope fields are constructed by plotting tiny line segments at various points in the $xy$-plane. The slope of each line segment is given by the value of $f(x, y)$ at that corresponding run-on-sentence$()$followed-by-another$DHF$group point. These line segments collectively form a field of slopes, hence the name ""slope field."" and more some-$yz$-something else'";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}