// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"(?m)\"(?<caller>[a-zA-Z0-9_\-\.]+@[a-zA-Z0-9_\-\.]+\.[a-zA-Z]{2,5})\",\"(?<receiver>[a-zA-Z0-9_\-\.]+@[a-zA-Z0-9_\-\.]+\.[a-zA-Z]{2,5})\""#).unwrap();
let string = " .....\"\",\"10/30/2018 7:31:08 AM\",\"10/30/2018 7:41:52 AM\",\"natalie.someone@email.com\",\"andrew.someone@email.com\",\"UCCAPI/3823.323.10827.* OC/16.0.10827.20150 (Skype for Business)\",\"UCCAPI/16.0.10730.2342342 OC/16.0.10730.20088 (Skype for Business)\",\"\",\"\",\"\",\"****-5042-5F76-A879-***7\",\"\",\"\",\"\",\"\",\"200\",\"[IM]\",\"{\"\"RequestType\"\":\"\"BYE\"\",\"\"RequestTime\"\":\"\"2018-10-30T07:41:52.2147589\"\",\"\"ContentType\"\":\"\"\"\",\"\"ResponseCode\"\":\"\"200\"\",..";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}