$re = '/\b(?<!,)[A-Z]/m';
$str = 'Varie Tutto l\'anno Nessuna Triennale,Magistrale Italia Alta';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);