package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^[0-9]{4}-([B-D]|[F-H]|[J-N]|[P-T]|[V-Z]){3}$`)
var str = `1234-BHB`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}