import re
regex = re.compile(r"[-|+]\d{0,3}.\d{2}(?=<span>PKT<\/span><.*col-xs-3)")
test_str = " type=\"text/javascript\">$(document).ready(function() { DynamicHeadLineTagResize($('div.snapshot-headline h2.font-resize'), 21, 0); });$(window).on('resize', function() { DynamicHeadLineTagResize($('div.snapshot-headline h2.font-resize'), 21, 0); });</script><div class=\"col-sm-7\"><div class=\"row quotebox\"><div class=\"col-xs-5 col-sm-4 text-sm-right text-nowrap\">13.161,08<span>PKT</span></div><div class=\"col-xs-4 col-sm-3 text-sm-right text-nowrap text-center red\">-3,56<span>PKT</span></div><div class=\"col-xs-3 col-sm-3 text-right text-nowrap red\">-0,16<span>%</span></div><div class=\"col-sm-2 col-xs-12 text-sm-right quotebox-option\"><div class=\"quotebox-time quotebox-time-bottom\">11:36:05 Uhr</div></div></div><div class=\"row hidden-xs relative\"><div class=\"col-xs-12\"><div class=\"pull-sm-right\"><div class=\"small-font light-grey pull-left mleft-sm-10 hidden-xs\">Anzeige</div>"
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")