re = /(?><.+?>)*((["'])(?:|(?:.*?)(?:[^\\]|[^\\]?(?:\\{2})+))\2)?/
str = '<abc "sss"><span class="key" id="id1">\'while\'</span>"te\\"s\\\\t2"<"fff">"test3"</A>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end