import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?<time>\\d{4}-\\d{1,2}-\\d{1,2} \\d{1,2}:\\d{1,2}:\\d{1,2}) \\[(?<thread>.*)\\] (?<level>[^\\s]+)(?<message>.*)";
final String string = "2013-3-03 14:27:33 [main] INFO Main - Start\n"
+ "2013-3-03 14:27:33 [main] ERROR Main - Exception\n"
+ "javax.management.RuntimeErrorException: null\n"
+ " at Main.main(Main.java:16) ~[bin/:na]\n"
+ "2013-3-03 14:27:33 [main] INFO Main - End";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}