import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(<.*>)|(<.*\\n)";
final String string = "<p><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- $25mm to $50mm near term GLRV opportunity. If approved, they would invest in our commingled\n"
+ "fund.</font></font><br><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- This was another critical step in Investcorp's investment process. In a\n"
+ "positive sign, they've decided to concurrently initiate operational due diligence on us and the GLRV fund/strategy.</font></font><br><font face=\"Helv\"\n"
+ "size=\"2\"><font face=\"Helv\" size=\"2\">- Overall an excellent, interactive meeting mainly focused on risk modeling and measurement, and how we use our \n"
+ "models/tools throughout the investment process to help source and implement trades; actively allocate risk across sub-strategies; as well as adjust the overall risk\n"
+ "taking in the strategy</font></font></p>\n\n"
+ "MEETING DETAILS:\n"
+ "None Available\n\n"
+ "NOTES:\n"
+ "<p><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- Investcorp is a NY based $10 billion global alternative investments manager with roots and a large\n"
+ "presence in the middle east.</font></font><br><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- They are running ~$2 billion in traditional FoHFs AUM (in\n"
+ "addition to another $2 billion in other custom HF mandates) after closing on their SSARIS Advisors (another FoHFs) acquisition earlier this\n"
+ "year.</font></font><br><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">- The consolidation of their portfolio continues following the SSARIS acquisition\n"
+ "and he team is finally ready to allocate to new managers. FI Arb/RV is a space they are interested in again.</font></font><br><font face=\"Helv\" size=\"2\"><font\n"
+ "face=\"Helv\" size=\"2\">- We have the advantage of being "first in the door" as they assessed the space, since we've been talking to them about LRV\n"
+ "since early 2014.</font></font><br><font face=\"Helv\" size=\"2\"><font face=\"Helv\" size=\"2\">";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}