re = /(^|\+|(?<=\s))(100|\d\d?)(?=(\s|$))/m
str = '0 Sam has 200 apples. He gives Todd 20 and Mary 125. and The weather is -5 C today, but will be +5 C tomorrow. 0 101 100'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end