package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)[yn]`)
var str = `ynYN`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}