$re = '/(?<!^dra\h)\b\w+\b\h*$/m';
$str = 'dra Julia
dr Marcos
dr Mateus
dra Ana';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);