$re = '/^(?=.*\d)(?=.*[A-Z])(?!.*(.)\1)\S{6,}/m';
$str = 'Abc#+123
123Abc#+
Abbc#+123
Abc##+123
Abc#+1223';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);