# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(in|out|ref) +w:(\d+) h:(\d+) fmt:(\w+) sar:(\d+)\/(\d+)(?: flags:0x[[:xdigit:]]+)?"
test_str = ("ffmpeg version N-86388-g3db98cad5c Copyright (c) 2000-2017 the FFmpeg developers\n"
" built with Apple LLVM version 8.1.0 (clang-802.0.42)\n"
" configuration: --enable-version3 --enable-gpl --enable-nonfree --enable-libass --enable-libfdk-aac --enable-libfreetype --enable-libmp3lame --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libx265\n"
" libavutil 55. 63.100 / 55. 63.100\n"
" libavcodec 57. 96.101 / 57. 96.101\n"
" libavformat 57. 72.101 / 57. 72.101\n"
" libavdevice 57. 7.100 / 57. 7.100\n"
" libavfilter 6. 91.100 / 6. 91.100\n"
" libswscale 4. 7.101 / 4. 7.101\n"
" libswresample 2. 8.100 / 2. 8.100\n"
" libpostproc 54. 6.100 / 54. 6.100\n"
"[Parsed_testsrc_0 @ 0x000000000000] size:320x240 rate:25/1 duration:-1.000000 sar:1/1\n"
"[Parsed_testsrc_1 @ 0x000000000000] size:640x360 rate:25/1 duration:-1.000000 sar:1/1\n"
"[Parsed_scale2ref_2 @ 0x000000000000] w:0 h:trunc((print(ow)*in_h+(in_w*7/2))/(in_h*7))*7 flags:'bilinear' interl:0\n"
"Stream mapping:\n"
" scale2ref:default -> Stream #0:0 (rawvideo)\n"
"Press [q] to stop, [?] for help\n"
"[Parsed_testsrc_0 @ 0x000000000000] size:320x240 rate:25/1 duration:-1.000000 sar:1/1\n"
"[Parsed_testsrc_1 @ 0x000000000000] size:640x360 rate:25/1 duration:-1.000000 sar:1/1\n"
"[Parsed_scale2ref_2 @ 0x7fa20d40efa0] w:0 h:trunc((print(ow)*in_h+(in_w*7/2))/(in_h*7))*7 flags:'bilinear' interl:0\n"
"0.000000\n"
"[Parsed_scale2ref_2 @ 0x000000000000] The width was set to 0 which will use the width of the reference input (640) not the main input (320).\n"
"[Parsed_scale2ref_2 @ 0x000000000000] Consider using: main_w\n"
"[Parsed_scale2ref_2 @ 0x000000000000] The height was set to 0 which will use the height of the reference input (360) not the main input (240).\n"
"[Parsed_scale2ref_2 @ 0x000000000000] Consider using: main_h\n"
"[Parsed_scale2ref_2 @ 0x000000000000] in w:320 h:240 fmt:rgb24 sar:1/1\n"
"[Parsed_scale2ref_2 @ 0x000000000000] ref w:640 h:360 fmt:rgb24 sar:1/1\n"
"[Parsed_scale2ref_2 @ 0x000000000000] out w:640 h:360 fmt:rgb24 sar:3/4 flags:0x2\n"
"Output #0, md5, to 'pipe:':\n"
" Stream #0:0: Video: rawvideo, 1 reference frame (RGB[24] / 0x18424752), rgb24, 640x360 [SAR 3:4 DAR 4:3], q=2-31, 138240 kb/s, 25 fps, 25 tbn, 25 tbc (default)\n"
" Metadata:\n"
" encoder : Lavc rawvideo\n"
"No more output streams to write to, finishing.\n"
"MD5=cf8c2055d282268025d43c621e468a83\n"
"frame= 5 fps=0.0 q=-0.0 Lsize= 0kB time=00:00:00.20 bitrate= 1.5kbits/s speed=7.37x \n"
"video:3375kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: unknown\n"
"Output file #0 (pipe:):\n"
" Output stream #0:0 (video): 5 frames encoded; 5 packets muxed (3456000 bytes); \n"
" Total: 5 packets (3456000 bytes) muxed\n")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.