package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(\?[^,]*),`)
var str = `https://community.domain.tld/register?to=3662%2354564894861351532416dzda#%frfgrzfz,categorie,dateAcces,,,
https://community.domain.tld/register?tests,categorie,dateAcces,,,
https://community.domain.tld/register,categorie,dateAcces,,,`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}