re = /^(?=.{8}$).*e/m
str = 'abcdefgh ijkemnop mnbvcxze
abcdefgh
ijkemnop
mnbvcxze'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end