re = /(https?:\/\/)?(www[.])?(telegram|t)\.me\/([a-zA-Z0-9_-]*)\/?$/
str = 'https://telegram.me/Amirhamini
https://t.me/Amirhamini'
# Print the match result
str.match(re) do |match|
puts match.to_s
end