$re = '/[0-9]{7}(-[0-9]{2,5})?/m';
$str = '1234567
1234567-12
1234567-12345
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);