package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^-?\d+$`)
var str = `123424124.215125`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}