using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<!\s)(\s)(?:\S+?)(?:\r\n?|\n|\z)";
string input = @"Some line of text ending witha line terminator
Always find the lsat word with or without a line terminator not including a Space
";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}