import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?P<species>[A-Z][^A-Z(]+)(?P<author>(?<!^).*)$";
final String string = "Dalbergia acutifoliolata Mendonca & Sousa\n"
+ "Dalbergia adami Berhaut\n"
+ "Dalbergia afzeliana G.Don\n"
+ "Dalbergia agudeloi J.Linares & M. Sousa\n"
+ "Dalbergia albiflora Hutch. & Dalziel\n"
+ "Dalbergia altissima Baker f.\n"
+ "Dalbergia amazonica (Radlk.) Ducke\n"
+ "Dalbergia amerimmon L. ex B.D.Jacks\n"
+ "Dalbergia andapensis Bosser & R.Rabev.\n"
+ "Dalbergia arbutifolia Baker\n"
+ "Dalbergia arbutifolia aberrans Polhill\n"
+ "Dalbergia armata E.Mey.\n"
+ "Dalbergia assamica Benth.\n"
+ "Dalbergia aurea Bosser & R.Rabev.\n"
+ "Dalbergia baronii Baker\n"
+ "Dalbergia bathiei R.Vig.\n"
+ "Dalbergia benthamii\n"
+ "Dalbergia berteroi\n"
+ "Dalbergia pseudo-sissoo Miq.\n"
+ "Dalbergia ovata var. glomeriflora (Kurz) Thoth.\n"
+ "Dalbergia albiflora subsp. albiflora";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}