import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "forward-zone:[.\\s]*name:[\\ \".\\s]*forward";
final String string = "## Simple recursive caching DNS, UDP port 53\n"
+ "## unbound.conf -- https://calomel.org\n"
+ "#\n"
+ "server:\n"
+ " access-control: 10.0.0.0/8 allow\n"
+ " access-control: 127.0.0.0/8 allow\n"
+ " access-control: 192.168.0.0/16 allow\n"
+ " cache-max-ttl: 14400\n"
+ " cache-min-ttl: 900\n"
+ " hide-identity: yes\n"
+ " hide-version: yes\n"
+ " interface: 0.0.0.0\n"
+ " minimal-responses: yes\n"
+ " prefetch: yes\n"
+ " qname-minimisation: yes\n"
+ " rrset-roundrobin: yes\n"
+ " use-caps-for-id: yes\n"
+ " verbosity: 1\n\n"
+ "forward-zone:\n"
+ " name: \".\"\n"
+ " forward-addr: 8.8.4.4 # Google\n"
+ " forward-addr: 8.8.8.8 # Google\n"
+ " forward-addr: 37.235.1.174 # FreeDNS\n"
+ " forward-addr: 37.235.1.177 # FreeDNS\n"
+ " forward-addr: 208.67.222.220 # OpenDNS\n"
+ " forward-addr: 208.67.222.222 # OpenDNS\n"
+ " forward-addr: 216.146.35.35 # Dyn Public\n"
+ " forward-addr: 216.146.36.36 # Dyn Public\n\n"
+ "forward-zone:\n"
+ " name: \"dns.com\"\n"
+ " forward-addr: 50.116.23.211 # OpenNIC\n"
+ " forward-addr: 64.6.64.6 # Verisign\n"
+ " forward-addr: 64.6.65.6 # Verisign\n"
+ " forward-addr: 74.82.42.42 # Hurricane Electric\n"
+ " forward-addr: 84.200.69.80 # DNS Watch\n"
+ " forward-addr: 84.200.70.40 # DNS Watch\n"
+ " forward-addr: 91.239.100.100 # censurfridns.dk\n"
+ " forward-addr: 109.69.8.51 # puntCAT\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}