$re = '/-(?![^(]*\))/';
$str = 'abc-1230-xyz-(def-ghu-jkl---)-(adsasa7asda12)-s-(klas-bst-asdas foo)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);