import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = ".*air_temp\": (\\d+).*";
final String string = " {\n"
+ " \"observations\": {\n"
+ " \"notice\": [\n"
+ " {\n"
+ " \"copyright\": \"Copyright Commonwealth of Australia 2017, Bureau of Meteorology. For more information see: http://www.bom.gov.au/other/copyright.shtml http://www.bom.gov.au/other/disclaimer.shtml\",\n"
+ " \"copyright_url\": \"http://www.bom.gov.au/other/copyright.shtml\",\n"
+ " \"disclaimer_url\": \"http://www.bom.gov.au/other/disclaimer.shtml\",\n"
+ " \"feedback_url\": \"http://www.bom.gov.au/other/feedback\"\n"
+ " }\n"
+ " ],\n"
+ " \"header\": [\n"
+ " {\n"
+ " \"refresh_message\": \"Issued at 12:11 pm EST Tuesday 11 July 2017\",\n"
+ " \"ID\": \"IDN60901\",\n"
+ " \"main_ID\": \"IDN60902\",\n"
+ " \"name\": \"Canberra\",\n"
+ " \"state_time_zone\": \"NSW\",\n"
+ " \"time_zone\": \"EST\",\n"
+ " \"product_name\": \"Capital City Observations\",\n"
+ " \"state\": \"Aust Capital Territory\"\n"
+ " }\n"
+ " ],\n"
+ " \"data\": [\n"
+ " {\n"
+ " \"sort_order\": 0,\n"
+ " \"wmo\": 94926,\n"
+ " \"name\": \"Canberra\",\n"
+ " \"history_product\": \"IDN60903\",\n"
+ " \"local_date_time\": \"11/12:00pm\",\n"
+ " \"local_date_time_full\": \"20170711120000\",\n"
+ " \"aifstime_utc\": \"20170711020000\",\n"
+ " \"lat\": -35.3,\n"
+ " \"lon\": 149.2,\n"
+ " \"apparent_t\": 5.7,\n"
+ " \"cloud\": \"Mostly clear\",\n"
+ " \"cloud_base_m\": 1050,\n"
+ " \"cloud_oktas\": 1,\n"
+ " \"cloud_type_id\": 8,\n"
+ " \"cloud_type\": \"Cumulus\",\n"
+ " \"delta_t\": 3.6,\n"
+ " \"gust_kmh\": 11,\n"
+ " \"gust_kt\": 6,\n"
+ " \"air_temp\": 9.0,\n"
+ " \"dewpt\": 0.2,\n"
+ " \"press\": 1032.7,\n"
+ " \"press_qnh\": 1031.3,\n"
+ " \"press_msl\": 1032.7,\n"
+ " \"press_tend\": \"-\",\n"
+ " \"rain_trace\": \"0.0\",\n"
+ " \"rel_hum\": 54,\n"
+ " \"sea_state\": \"-\",\n"
+ " \"swell_dir_worded\": \"-\",\n"
+ " \"swell_height\": null,\n"
+ " \"swell_period\": null,\n"
+ " \"vis_km\": \"10\",\n"
+ " \"weather\": \"-\",\n"
+ " \"wind_dir\": \"WNW\",\n"
+ " \"wind_spd_kmh\": 7,\n"
+ " \"wind_spd_kt\": 4\n"
+ " },\n"
+ " {\n"
+ " \"sort_order\": 1,\n"
+ " \"wmo\": 94926,\n"
+ " \"name\": \"Canberra\",\n"
+ " \"history_product\": \"IDN60903\",\n"
+ " \"local_date_time\": \"11/11:30am\",\n"
+ " \"local_date_time_full\": \"20170711113000\",\n"
+ " \"aifstime_utc\": \"20170711013000\",\n"
+ " \"lat\": -35.3,\n"
+ " \"lon\": 149.2,\n"
+ " \"apparent_t\": 4.6,\n"
+ " \"cloud\": \"Mostly clear\",\n"
+ " \"cloud_base_m\": 900,\n"
+ " \"cloud_oktas\": 1,\n"
+ " \"cloud_type_id\": 8,\n"
+ " \"cloud_type\": \"Cumulus\",\n"
+ " \"delta_t\": 2.9,\n"
+ " \"gust_kmh\": 9,\n"
+ " \"gust_kt\": 5,\n"
+ " \"air_temp\": 7.3,\n"
+ " \"dewpt\": 0.1,\n"
+ " \"press\": 1033.1,\n"
+ " \"press_qnh\": 1031.7,\n"
+ " \"press_msl\": 1033.1,\n"
+ " \"press_tend\": \"-\",\n"
+ " \"rain_trace\": \"0.0\",\n"
+ " \"rel_hum\": 60,\n"
+ " \"sea_state\": \"-\",\n"
+ " \"swell_dir_worded\": \"-\",\n"
+ " \"swell_height\": null,\n"
+ " \"swell_period\": null,\n"
+ " \"vis_km\": \"10\",\n"
+ " \"weather\": \"-\",\n"
+ " \"wind_dir\": \"NW\",\n"
+ " \"wind_spd_kmh\": 4,\n"
+ " \"wind_spd_kt\": 2\n"
+ " }\n"
+ " ]\n"
+ " }\n"
+ "}";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}