$re = '/(?i)(cat)\1/m';
$str = 'cat cat
CAT Cat
Cat cat
Cat Cat
CAT CAT';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);