import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<spaceBefore>^[ \\t]*)(?<function>SetColor|SetAlpha|DrawRect|Delay|Flip|SetScale|SetVirtualResolution|CloseStream)[ \\t]*(?!\\()(?<parameters>[\\w \\(\\)\\-,\\.\\/\\[\\]\\*\\t\\+]+)?;?";
final String string = " \n"
+ " DrawRect barX-2 ,barY-2 ,barW+4 ,barH+4 ;\n"
+ " SetColor rgb[0]*colorMultipler,rgb[1]*colorMultipler,rgb[2]*colorMultipler;\n"
+ "public static TImage DelayTimer_in=BM\n"
+ "SetAlpha - float(n) / Fade1 //nn\n"
+ " DrawRect 0, 0,tApplication.ScrW(),tApplication.ScrH();\n"
+ "SetVirtualResolution(SourceScreenWidth, SourceScreenHeight);\n"
+ "SetColor 0, 0, 0\n"
+ "Delay 10; //mmm\n"
+ "Flip;\n"
+ "SetScale 10, 10;\n"
+ " CloseStream tLog.file; \n";
final String subst = "$1$2\\($3\\);";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}