import re
regex = re.compile(r"password\s+for\s+(user|(invalid\s+user))\s+(?<User>\w+)\s+from\s+(?<Source_IP>\d+\.\d+\.\d+\.\d+)\s+port\s+(?<Source_Port>\d+)\s+(?<Protocol>\w+)", flags=re.MULTILINE)
test_str = ("Jun 3 17:29:44 ntp sshd[9668]: Failed password for invalid user XXX from 192.168.111.111 port 63568 ssh2\n"
"· host = ntp 192.168.XXX.XXX\n"
"· source = /var/log/secure\n"
"· sourcetype = linux_secure\n\n"
"Jun 3 17:29:44 XXX sshd[9668]: Failed password for user XXX from 192.168.111.111 port 63568 ssh2\n"
"· host = 10.0.0.XXX\n"
"· source = /var/log/secure\n"
"· sourcetype = linux_secure\n\n"
"Jun 3 00:13:41 XXX sshd[18404]: Accepted password for user XXX from 192.168.111.111 port 60272 ssh2\n"
"· host = 10.0.0.XXX\n"
"· source = /var/log/secure\n"
"· sourcetype = linux_secure")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")